匯豐HSBC的網上銀行不支援FIREFOX?

昨日還能用Iceweasel(Firefox in Debian)登入HSBC的網上銀行服務。

豈料今日早上登入時,

出現這句

We regret that HSBC Internet Banking must be viewed by either Internet Explorer 6.0 (or later versions) or Netscape Navigator 7.1 (or later versions). You may visit http://www.microsoft.com or http://home.netscape.com to download a compatible browser.

hsbc

本人用DEBIAN,因此沒有辦法,立即下載NETSCAPE9。

怎料下載完成後,在執行時出現

./navigator-bin: error while loading shared libraries: libmozjs.so: cannot open shared object file: No such file or directory

真是……

最後是,用了一個FIREFOX的PLUGIN, user agent switcher去扮IE,

於是成功進入到HSBC的EBANKING系統,並能正常使用,沒有任何問題。

問過其他同事及朋友,他們都同樣地出現Firefox不能登入,

但IE和NETSCAPE能正常使用的問題。

不明白的是, 原本他們的網上銀行系統一直都支援FIREFOX,

今日突然話不支援,但轉了USER AGENT後就能正常進入,

而且沒有任何問題。

經投訴,HSBC回覆是因他們銀行系統發生故障,正在修理中。

希望正如他們所言,真的只是故障,而不是封殺FIREFOX。

Leave a Reply

Your email address will not be published. Required fields are marked *